ABSTRACT
You just got the results of the study and you want to get some quick graphical views of the data before you begin the analysis. Do you need a crash course in the SG procedures just to get a simple histogram? What to do?

The ODS Graphics Designer is the answer. With this application you can create many graphs including histograms, scatter plots, scatter plot matrices, classification panels and more using an interactive ‘drag-and-drop’ process. You can render your graph in batch with new data and output the results to any open destination. You can view the generated GTL code as a leg up to GTL programming. You can do all this without cracking the book or breaking a sweat.

INTRODUCTION

ODS Graphics Designer is a new interactive application released with the third maintenance release for SAS 9.2 as part of the SAS/GRAPH® product. This application is designed for users who prefer to create their graphs using an interactive application. It presents you with a graphical user interface that takes the pain out of creating graphs, and makes it easy.

The designer is based on Graph Template Language (GTL), the syntax used to create analytical graphs now produced by the SAS analytical procedures. GTL is a very extensive syntax, designed to allow procedure writers all the features and flexibility they need to create their complex graphs. The designer uses the “Pareto principle,” also known as the 80-20 rule, to drive a subset of the GTL features that are necessary to create many different graphs.

Starting with SAS 9.3, the designer became available as part of Base SAS®.

GETTING STARTED

With the third maintenance release for SAS 9.2, you can start the designer by submitting the following macro code from the Program Editor window:

```
%sgdesign;
```

With SAS 9.3, you can start the designer from the Tools->ODS Graphics Designer menu entry. You can also use the above macro code.

In both cases, the designer application is started, and the following splash screen is displayed:

![Splash Screen](Figure 1.1)
THE DESIGNER APPLICATION INTERFACE

Once the ODS Graphics Designer application is running, you will see the application window as shown in Figure 1.2. The key features of the application interface are:

1. The menus and menu bar along the top
2. The Elements panel on the left side
3. The workspace on the right side
4. The Graph Gallery in the workspace

THE MENUS AND THE MENU BAR

The menus for the application are displayed along the top with the following features.

- **File**: Create a new graph, open a graph, or save a graph and other actions.
- **Edit**: Undo, Redo, Select. and Copy.
- **View**: Display or hide the Graph Gallery, Elements Panel, or the Code window.
- **Insert**: Insert objects into a graph, such as title, footnote, legend, rows, and columns.
- **Format**: Set the visual properties of different components of the graph.
- **Tools**: Start the Graph Style Editor or set user preferences.
- **Help**: See the release level and license information for the designer.

Frequently used actions from the menus are also available as buttons on the menu bar.

THE ELEMENTS PANEL

The Elements panel is on the left side of the window and is initially inactive. The Elements panel is organized into two groups - Plots Layers and Insets. Once a graph has been created, the Elements panel becomes active, and you can drag and drop plots and insets from the Elements panel to the graph.
THE WORKSPACE
To the right of the application window is the workspace. The items that can exist in this space are:

- One or more graphs
- The GTL code window for the active graph
- The Graph Gallery

THE GRAPH GALLERY
When the application starts, the Graph Gallery is displayed in the workspace. As shown in Figure 1.3, the Graph Gallery contains a set of frequently used graphs organized in the following tabs arranged along the top of the gallery:

- Basic: A set of commonly used single plot graphs
- Grouped: A set of graphs classified by a group variable
- Analytical: A set of commonly used graphs for analysis of data
- Custom: A set of unique graphs that require some customized data
- Matrix: A set of scatter plot matrix graphs with common options
- Panels: A set of multi-cell graphs classified by one or two classifiers

User-defined groups can be added to the gallery, and will be shown as additional tabs along the top. You can organize the Graph Gallery to your needs by using the “Organize” feature at the bottom left.

Note: The groups shown above along with the graphs in each group are shipped with the designer. You cannot modify or delete these groups or the graphs in them, though you can hide them.

![Graph Gallery](image)

**Figure 1.3 – Graph Gallery**

EXERCISE 1 – EXPLORING THE USER INTERFACE
When the application first comes up, there is no active graph in the workspace. So, the Elements panel is inactive. However, you can explore other elements of the GUI.

1. You can explore the graphs available in the different tabs of the Graph Gallery. Click on each tab to see the types of graphs included in that group.
2. You can explore the menu options available under each of the menus along the top.

Exploring the rest of the user interface of the application will be easier once we have created a graph. So let us move on to the hands-on exercises and build some graphs.
EXERCISE 2 – DISTRIBUTION OF HAMILTON SCORES

In this exercise, we will create the graph shown in Figure 2.2, a graph showing the distribution of Hamilton scores for depression in a study. The Hamilton score is a value between 0 and 32. Higher values indicate higher levels of depression. The data set is shown in Figure 2.1, where BASVAL is the score for each patient. The columns Score and Level define the ranges of scores for each level of depression. These two columns are standard values, and have been merged into the data set, and will be used to display the level bands.

<table>
<thead>
<tr>
<th>Obs</th>
<th>BASVAL</th>
<th>score</th>
<th>level</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>25</td>
<td>0</td>
<td>Normal</td>
</tr>
<tr>
<td>2</td>
<td>18</td>
<td>6</td>
<td>Normal</td>
</tr>
<tr>
<td>3</td>
<td>21</td>
<td>7</td>
<td>Mild</td>
</tr>
<tr>
<td>4</td>
<td>10</td>
<td>17</td>
<td>Mild</td>
</tr>
<tr>
<td>5</td>
<td>19</td>
<td>18</td>
<td>Moderate</td>
</tr>
<tr>
<td>6</td>
<td>19</td>
<td>24</td>
<td>Moderate</td>
</tr>
<tr>
<td>7</td>
<td>15</td>
<td>25</td>
<td>Severe</td>
</tr>
<tr>
<td>8</td>
<td>9</td>
<td>32</td>
<td>Severe</td>
</tr>
<tr>
<td>9</td>
<td>13</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>18</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 2.1 – Data

The graph contains the following plots:

- A histogram of BASVAL
- A normal density curve of BASVAL
- A kernel density curve of BASVAL
- A block plot showing the depression levels by score
- A legend and a title

Let us now create this graph step-by-step.

1. **Create a histogram from the Graph Gallery**
   a. Click on the Histogram icon in the Graph Gallery and select OK.
   b. A graph is created with a histogram using SASHELP.CLASS as a place holder data set.
   c. The Assign Data dialog box is displayed.

2. **Assign the data for the histogram**
   a. Set **Library**: Designer
   b. Set **Data Set**: Depress
   c. Set **X**: BasVal
   d. Click OK.

3. **Set the title, remove the footnote**
   a. A graph from the gallery comes with default place holder title and footnote.
   b. Click on the title and change it to "Hamilton Scores for Depression".
   c. Right-click on the footnote and select **Remove Footnote**.
4. **Remove the X-axis label**
   a. Right-click on the X-axis and select **Axis Properties**...
   b. Uncheck the **Label** check box.

5. **Add a normal density curve**
   a. Drag the Normal density icon from the **Plot Layers** panel on to the graph.
   b. The **Assign Data**... dialog box is displayed.
   c. The **Library** and **Data Set** fields are preselected and disabled.
   d. **Fit an Existing Plot** is checked. Select OK.

6. **View the code**
   a. Select **View->Code**.
   b. The code window is displayed for the active graph.
   c. Examine the GTL code.

7. **Add a kernel density curve**
   a. Drag the Kernel density icon from the **Plot Layers** panel to the graph.
   b. The **Assign Data**... dialog box is displayed.
   c. The **Library** and **Data Set** fields are preselected and disabled.
   d. **Fit an Existing Plot** is checked. Select OK.

8. **Explore the popup menu**
   a. Right-click the graph. The **popup menu** is displayed.
   b. Select **Cell Contents** to view all the plots in the graph. You can reorder or remove a plot.
   c. Select **Add an Element**. The plots that can be added to the graph are displayed.
   d. Select **Graph Properties**. You can customize properties of the whole graph from here.

9. **Set plot properties**
   a. Right-click a plot and select **Plot Properties**.
   b. The **Cell Properties** dialog box is displayed, with the **Plots tab** selected.
   c. Select the plot name kernel in the **Plot** drop down list.
   d. Set **Style Element** to GRAPHFIT2 and **Pattern** to solid.

10. **Add a block plot**
    a. Drag the Block icon from the Plot Layers panel on to the graph.
    b. The **Assign Data** dialog box is displayed.
    c. The **Library** and **Data Set** fields are preselected and disabled.
    d. Set **X=Score**, **Block=Level**
    e. Keep **Position=Center**. Click OK.

11. **Set block plot properties.**
    a. Right-click the Block plot and select **Plot Properties**.
    b. The **Plot Properties** dialog box is displayed. The **Plot tab** and Block plot are selected.
    c. Check the **Value** check box. Now the values for each block are displayed.
    d. Select the **Value tab**.
        i. In the **Alignment** box, set **Horizontal=Center** and **Vertical=Top**
    e. Select the **Fill tab**.
        i. Set **Alt Fill Color Style Element** to GraphWalls.

12. **Set the Y axis range and ticks values**
    a. Note, the block values are colliding with the top of the histogram.
    b. Right-click on the Y-axis and select **Axis Properties**.
    c. Click the **Advanced tab**.
    d. Check the **Custom Axis Range** check box, and set **Max=18**. Click OK.
13. **Add a discrete legend**
   a. Drag the DiscreteLegend icon from the Insets panel and drop it onto the right edge of the graph.
   b. A legend is added at the drop location, with all the plots in the cell included in the legend.
   c. Right-click on the legend and select Legend Contents.
   d. Uncheck the histogram check box.
   e. Double-Click on the legend label for normal, and change it to Normal.
   f. Similarly, change the legend label for kernel to Kernel. Click OK.

14. **Set the Graph properties**
   a. Right-click on the graph and select Graph Properties.
   b. Uncheck the Keep Aspect Ratio box.
   c. Set Width=500 and Height=350.
   d. Click OK.

**EXERCISE 3: SAVE THE GRAPH TO A FILE OR THE GRAPH GALLERY**

1. **File->Save As…**
   1. The Save As dialog box is displayed.
   2. Default output type is SGD.
   3. Assign a filename.
   4. Click OK.
   5. You can also set the output file type to industry standard formats such as PNG, JPG, and so on.
   6. For PNG, you can select a DPI.
   7. For HTML, you can select a Target.

2. **File->Save In Graph Gallery**
   1. Select a group name (create a new one if necessary).
   2. Assign a graph name.
   3. An icon for the graph is automatically built from the graph itself. You can select another icon from the file system if necessary.
   4. Assign a tooltip description (optional).
   5. Click OK.

The graph icon is automatically created.
EXERCISE 4: MAKE A MULTI CELL DISTRIBUTION PLOT

Now, let us add a 2nd way to visualize the distribution of the data, using a box plot as shown in Figure 4.1. To do this, we will take the following steps:

- Split the graph into two cells.
- Add a horizontal box plot to the lower cell.
- Make the X-axis common (and uniform).

![Figure 4.1 – Box Plot and Density Distribution](image)

1. **Add a row to the graph**
   a. Right-click on the graph and select **Add a Row**.
   b. The graph is split in two, and an empty cell is added at the bottom.

2. **Add a horizontal box plot**
   a. Drag the icon for the **HBOX(H)** to the lower cell.
   b. The **Assign Data** dialog box is displayed.
   c. Accept the current **Library** and **Data** assignment.
   d. Set **Y=Basval**, **X=none**. Click OK.

3. **A horizontal box plot is added to the bottom cell, with its own axes**
   a. Note: Both cells have their own X-axes.
   b. Note: The X-axis for upper and lower cells are not uniform.

4. **Make X-axis common**
   a. Right-click on any X-axis and select **Common Column Axis**
   b. Now, only one common X-axis is shown, and all plots are scaled to this axis.

5. **Change the X-axis tick values**
   a. Right-click on the X-axis and select **Axis Properties**.
   b. Select the **Advanced** tab.
   c. Check the **Tick Sequence** check box.
   d. Set **Start=0**, **End=35**, **Inc=5**.
   e. Note, the ‘35’ tick mark and value are not displayed due to the **Threshold** feature in GTL.

6. **Resize the lower cell**
   a. Position the cursor between the two cells, and you will see a resize cursor.
   b. Click and drag the mouse down to reduce the size of the lower cell.
EXERCISE 5: GRAPH TERMINOLOGY

In the designer, you can create many different types of graphs, from simple single-cell graphs to more complex multi-cell comparative graphs and classification panels. It is useful to have a common terminology as we describe the different parts of a graph.

1. The single output (file or image) from the designer is called the graph.

2. A graph can contain the following:
   a. Zero or more title(s) at the top and footnotes(s) at the bottom.
   b. One or more cells containing individual plots.
   c. Zero or more global legends.
   d. The example shown above is a graph with two cells.

3. A cell can contain the following:
   a. One or more plots representing the data.
   b. In the above graph, the upper cell has four plots and the lower cell has one plot.
   c. Each cell supports up to four axes: X (bottom), Y (left), X2 (top) and Y2 (right).
   d. Zero or more cell legends.

4. A plot has data and properties
   a. A plot can be assigned to any set of X/X2 and Y/Y2 axes.
   b. Use the Assign Data dialog box to set or change the data assignment.
   c. Use the Plot Properties dialog box to set plot visual attributes.

5. Axes:
   a. Each cell has its own independent set of X, Y, X2, and Y2 axes.
   b. Use the Axis Properties dialog box to customize the axes.
   c. For a multi-cell graph, X and / or Y axes can be independent or uniform.
   d. For a multi-cell graph, common, shared row and column axes can be used.
EXERCISE 6: SURVIVAL PLOT (EXAMPLE FROM LIFETEST PROCEDURE DOCUMENTATION)

In this exercise, we will create a survival plot showing the survival probability by treatment over time along with the At Risk table of the number of patients in the study. The data used comes from an example for the LIFETEST procedure. We have run the program shown in the example, and saved the survival data to a data set using the ODS Output statement for use in the designer to create the graph.

<table>
<thead>
<tr>
<th>Obs</th>
<th>Time</th>
<th>AtRisk</th>
<th>tAtRisk</th>
<th>Stratum</th>
<th>StrNum</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.00000</td>
<td>38</td>
<td>0</td>
<td>1: ALL</td>
<td>All</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>38</td>
<td>.</td>
<td>0: ALL</td>
<td>All</td>
</tr>
<tr>
<td>3</td>
<td>0.97368</td>
<td>38</td>
<td>1</td>
<td>1: ALL</td>
<td>All</td>
</tr>
<tr>
<td>4</td>
<td>55.94737</td>
<td>37</td>
<td>1</td>
<td>1: ALL</td>
<td>All</td>
</tr>
<tr>
<td>5</td>
<td>74.92105</td>
<td>36</td>
<td>1</td>
<td>1: ALL</td>
<td>All</td>
</tr>
<tr>
<td>6</td>
<td>86.89474</td>
<td>35</td>
<td>1</td>
<td>1: ALL</td>
<td>All</td>
</tr>
<tr>
<td>7</td>
<td>104.88642</td>
<td>34</td>
<td>1</td>
<td>1: ALL</td>
<td>All</td>
</tr>
<tr>
<td>8</td>
<td>107.84211</td>
<td>33</td>
<td>1</td>
<td>1: ALL</td>
<td>All</td>
</tr>
<tr>
<td>9</td>
<td>109.81579</td>
<td>32</td>
<td>1</td>
<td>1: ALL</td>
<td>All</td>
</tr>
<tr>
<td>10</td>
<td>110.78947</td>
<td>31</td>
<td>1</td>
<td>1: ALL</td>
<td>All</td>
</tr>
</tbody>
</table>

Figure 6.1 – Survival Plot Data

Figure 6.2 – Survival Plot

1. **Open a new blank graph**
   a. Use File->New->Blank Graph. A new blank graph is created.

2. **Add a step plot**
   a. Drag the icon for the Step plot from the Elements panel to the graph.
   b. The Assign Data dialog box is displayed.
   c. Use Designer.SurvivalPlotData.
   d. X=Time, Y=Survival, Group=stratum.
   e. Set the plot name to Survival.

3. **Add a global legend**
   a. Select Insert->Global Legend. The Global Legend dialog box is displayed.
   b. Check the check box for the Survival plot. Click OK.
   c. The legend is added to the bottom of the graph.

4. **Add titles**
   a. Select Insert->Title. A title is inserted at the top of the graph. Customize the title.
   b. Select Insert->Title to add a second title. Add the title text and reduce the font size.

5. **Add a scatter plot for CENSORED**
   a. Drag the Scatter icon from the Plot Layers panel to the graph.
   b. The Assign Data dialog box is displayed.
   c. Set X=Time, Y=Censored.
   d. Set plot Name to Censor.

6. **Set marker symbol to +**
   a. Right-click on the graph and select Plot Properties.
   b. Select the plot name in the Plot list.
   c. Change the symbol to +.
7. **Add a scatter plot for CENSORED by STRATUM**
   a. Drag the Scatter icon from the Plot Layers panel to the graph.
   b. The Assign Data dialog box is displayed.
   c. Set X=Time, Y=Censored, **Group**=Stratum.
   d. Set the plot **Name** to CensorGroup.

8. **Set the marker symbol to +**
   a. Right-click on the graph and select Plot Properties.
   b. Select the plot name in the Plot list.
   c. Change the symbol to +.

9. **Add a legend for CENSORED, keeping only the non-group censor plot**
   a. Drag the Discrete Legend icon from the Insets panel to the upper right corner of the graph.
   b. The legend is added containing all the plot statements in the cell.
   c. Right-click on the legend and select Legend Contents.
   d. Uncheck all the check boxes except Censor.

10. **Add a stacked block plot**
    a. Drag the StackBlock icon from the Plot Layers panel on to the graph.
    b. The Assign Data dialog box is displayed.
    c. The Library and Data Set name fields are inactive.
    d. Set X= TatRisk, **Block**= AtRisk, **Group**= Stratumnum.
    e. Set the plot **Name** to At Risk.
    f. Set Position=Bottom.

11. **Set block plot properties**
    a. Right-click on the block plot and select Plot Properties.
    b. Check the **Label** check box and uncheck the **Fill** and **outline** check boxes.
    c. Select the **Value** tab.
    d. In the Alignment box, set **Horizontal** to Start.
EXERCISE 7: SURVIVAL PLOT

In this example, we will start with the plot created in Exercise 6, and move the “At Risk” table to outside the survival curves cell as shown in Figure 7.2.

<table>
<thead>
<tr>
<th>Obs</th>
<th>Tim</th>
<th>AtRisk</th>
<th>Event</th>
<th>cAtRisk</th>
<th>Stratum</th>
<th>StrNum</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0.00000</td>
<td>38</td>
<td>0</td>
<td>.1:ALL</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>38</td>
<td>.</td>
<td>0:1:All</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>3</td>
<td>1.09736</td>
<td>38</td>
<td>1</td>
<td>.1:All</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>4</td>
<td>55.94737</td>
<td>37</td>
<td>1</td>
<td>.1:All</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>5</td>
<td>74.92105</td>
<td>36</td>
<td>1</td>
<td>.1:All</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>6</td>
<td>86.89474</td>
<td>35</td>
<td>1</td>
<td>.1:All</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>7</td>
<td>104.86842</td>
<td>34</td>
<td>1</td>
<td>.1:All</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>8</td>
<td>107.84211</td>
<td>33</td>
<td>1</td>
<td>.1:All</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>9</td>
<td>109.81579</td>
<td>32</td>
<td>1</td>
<td>.1:All</td>
<td>All</td>
<td>All</td>
</tr>
<tr>
<td>10</td>
<td>110.78947</td>
<td>31</td>
<td>1</td>
<td>.1:All</td>
<td>All</td>
<td>All</td>
</tr>
</tbody>
</table>

Figure 7.1 – Data  
Figure 7.2 – Graph

1. Remove the block plot and bottom legend
   a. Right-click on the block plot and select Remove Plot.
   b. Right-click on the bottom legend and select Remove Legend.

2. Add a discrete legend to the Survival Curves cell
   a. Drag and drop the Discrete Legend icon to the bottom of the cell.
   b. Right-click on the legend and select Legend Contents.
   c. Check the Survival plot and uncheck all other plots.

3. Add a cell row to the graph
   a. Right-click on the graph and select Add a Row.
   b. The graph area will be split into two rows of cells of equal height.

4. Add the At Risk table to the bottom cell using a stacked block plot
   a. Drag the StackBlock icon from the Plot Layers panel on to the new cell.
   b. Use the same data set: Designer.SurvivalPlotData.
   c. Set X=TatRisk, Block=AtRisk, Group=Stratumnum.

5. Set block plot properties
   a. Uncheck Fill and Outline and check Label.
   b. In the Value tab, set Horizontal Alignment=START.

6. Make both X axes uniform and hide the bottom X axis
   a. Right-click on the lower X axis, and select Axis Properties.
   b. At the bottom of the Axis dialog box, set Data Range to Union.
   c. Uncheck Label, Value, and Ticks.

7. Reduce the height of the lower cell
   a. Position the cursor just above the lower cell until the “Resize” arrow cursor is displayed.
   b. Click and drag down the border between the cells.
EXERCISE 8: SURVIVAL PLOT

The graph we created in Exercise 7 delivers the relevant information. However, it is traditional in the clinical industry to place the stratum legend below the survival curves, outside the cell, as shown in Figure 8.2.

However, the designer application GUI supports legends inside cells only, or completely outside all cells, at the bottom or top of the graph. So how do we get from Figure 8.1 to Figure 8.2?

As mentioned earlier, the designer GUI is really a code generator for GTL syntax. We can copy the current state of the syntax for Figure 8.1 and paste it into the SAS Program Editor window. Then we can make a small change to the syntax to get the graph in Figure 8.2.

We need to get the GTL code created so far by the designer, and then modify it a bit and submit the code as a GTL program using the SGRENDER procedure.

1. Open the Code window by selecting View->Code.
2. Highlight all the code and select Edit->Copy.
3. In the SAS application window, open a new Program Editor window, and paste the code.
4. In the second DISCRETELEGEND statement, change the option LOCATION=OUTSIDE.
5. Provide a name for the graph by adding this code above the PROC SGRENDER step:

   ods graphics / reset imagename='Ex-8-SurvivalPlot-3';
   a. This step is not strictly necessary, as a default filename will be used if one is not provided.
   b. We just want a name we can easily identify the graph.
6. Submit the program.
   a. The new graph is written to the file "C:\how\matange\Ex-8-SurvivalPlot-3.png"
   b. This graph has the STRATUM legend below the X-axis.

---

**Figure 8.1 – Graph from Exercise 7**

**Figure 8.2 – Traditional Survival Plot**
EXERCISE 9: CLASSIFICATION PANEL

A classification panel is a multi-cell graph, where the number of cells is determined by the levels of the class variable(s). In this exercise, we will create a Box Plot of Systolic blood by death cause classified by sex.

1. Open a new blank plot

2. Add a vertical box plot.
   a. Select the WORK.HEART data set.
   b. Set Analysis = Systolic
   c. Set Category=DeathCause.
   d. Press OK to see the boxplot.
   e. Add a title “Systolic Blood Pressure by Death Cause”

3. Press right mouse in the graph and select Assign Data.
   a. Select the Panel Variables tab.
   b. Select Data Lattice
   c. Set Column=Sex.

4. Press right mouse in the graph and select Graph Properties.
   a. Uncheck the Keep Aspect Ratio.
   b. Set width to 600 and height to 360 pixels.
   c. Set DataSkin=Gloss.
EXERCISE 10: CLASSIFICATION LATTICE

A classification lattice is a multi-cell graph, where the number of cells is determined by the levels of the class variable(s). In this exercise, we will add a row variable to create a Box Plot of Systolic blood by death cause classified by sex and weight status.

![Systolic Blood Pressure by Death Cause Classified by Sex and Weight Status](image)

1. Now, let us make the graph from Exercise 9 taller for a row classifier
   a. Press right mouse in the graph and select Graph Properties.
   b. Uncheck the Keep Aspect Ratio.
   c. Set width to 600 and height to 600 pixels.

2. Now, let us add the weight_status as the Row variable.
   a. Press right mouse in the graph and select Assign Data.
   b. Select the Panel Variables tab.
   c. Set Row=weight_status.
EXERCISE 11: RUNNING DESIGNER GRAPHS IN BATCH

1. Open "C:\how\matange\exercises\Stockplot.sgd.
2. Review the plot features.
3. Note the use of dyn(name) in title.
4. Return to the SAS program window.
5. Open "C:\how\matange\code\Stockplot.sas.
6. Review the code.
7. Submit the code to see output of graphs in open destinations.

ADDITIONAL TOPICS

1. Managing the Graph Gallery.
2. Using the Style Editor.
3. Creating Shared Variable Graphs.

CONCLUSION

The ODS Graphics Designer is a valuable interactive application for creating graphs. Whether you want a quick view of your data before starting the analysis, or a custom graph from the results of your analysis, the ODS Graphics Designer can get you started and on your way without the need to know a shred of graph syntax. Once you have your graph, you can then use it to render the same graph with different data in a batch process. You can even get the generated GTL code from the application for further customization.

If you are familiar with the SG Procedures and GTL programming, the designer can be a good tool for fast prototyping to try out different graph layouts and options before you settle on the final look of your graph.

CONTACT INFORMATION

Your comments and questions are valued and encouraged. Contact the author:

Sanjay Matange
SAS Campus Drive
SAS Institute Inc.
E-mail: Sanjay.Matange@sas.com

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.