ABSTRACT

The report building functions in SAS® Enterprise Guide® allow greater ability to create and publish final documents from multiple project tasks and reports. This tutorial demonstrates how to leverage the power of SAS while using the handy features of Enterprise Guide to create a process flow for generating reports. Topics covered include: navigating the Enterprise Guide menus, creating a report with the Report Builder wizard, combining reports and tasks into a single document using Report layout, and using prompts to generate custom reports from a template.

INTRODUCTION

This paper was first presented in the Tutorial section of the 2010 Western Users of SAS Software (WUSS) conference and updated for presentation at the Pharmaceutical Industry SAS® Users Group 2012 Annual Conference (PharmaSUG 2012). The main purpose is to demonstrate ways to create and automate reports using the many available tasks and functions in Enterprise Guide. It is intended for SAS programmers with less experience with Enterprise Guide or those that would like to learn handy tips on automating code and processes for a project. The reporting features of Enterprise Guide, versions 4.2 and later, are briefly described as are examples of functions for updating reports on a continued basis.

This is the description of SAS Enterprise Guide from a SAS White Paper on the SAS website (EG Fact Sheet): “SAS® Enterprise Guide® provides an easy-to-use interface to access the power of SAS data access, reporting and analytics, enabling you to quickly create and publish SAS Stored Processes that can be leveraged from Microsoft Office applications or Web browsers.”

This figure taken from the SAS website is a visualization of the description above. It accurately displays how the powerful SAS engine is under the hood of the nice graphical user interface of Enterprise Guide allowing users to perform jobs quickly and easily.

GETTING FAMILIAR WITH THE ENTERPRISE GUIDE INTERFACE

This section is just a brief overview on the Enterprise Guide interface. For those familiar with the look of Enterprise Guide, please look forward to the next sections of this paper.

At first glance, the application looks very menu driven and can be unpleasant to traditional SAS programmers. It took me a while to reconcile the log and output windows. After time, I came to realize that the Enterprise Guide interface has many more features than the Display Manager seen in SAS. The key to getting accustomed to Enterprise Guide is learning how to work with process flows.
First, all work is organized in one file called a **Project** with the file extension “.epg”. A sample project is shown below. As you can see all code, data, log and output are contained in the project and represented as **Nodes** (the icons) shown in the **Process Flow** window. So the process flow represents your desktop that charts all your work. I find this process flow window useful because projects can be broken into steps. For example, instead of 1000 lines of code in one program that don’t have natural breaks you can have 4 or 5 programs as steps within a process flow. This is explained later in the paper. You can always export all code to a single program file by going to **File → Export → Export All Code**. The **Process Flow** and **Project Tree** windows give programmers an easy view of your entire project. You can also pull existing SAS programs into your project with shortcuts (non-embedded programs) or place the programs into the project (embedded programs).

### Changing SAS Enterprise Guide Settings

If you would like to change the SAS Enterprise Guide environment such as Project Tree views and outputted results, go to the **Tools → Options**. The most relevant option for this tutorial is the **Results → Results General** option, where you change the format of your output. You can choose to generate SAS Report, HTML, PDF, RTF, and/or text files.
CREATING REPORTS WITH TASK WIZARDS

Results and reports are easily generated with the many available task wizards in Enterprise Guide. Graphs and reports that are seemingly tedious and time consuming to code can be created with a few steps in a wizard. Also, you are not stuck with one particular result after the wizard. That is, you can use the code generated by Enterprise Guide (explained later in this section).

For the remainder of this paper I use the SASHELP.CARS data set from the SASHELP library. This data set has 428 observations and 15 variables. It basically contains data on make and models of cars, such as miles per gallon, number of cylinders. There are 5 character variables, and 2 currency variables and 8 numeric variables.

To create a quick report on this data set, I use the List Report task from the Task List window in the resources pane (see red arrow in figure below). The CARS data set must be in the Process Flow. You can do this by opening the data set from the Server List or Explorer window (lower left window) or by opening the data set by going to New → Data Set. Once the data set is open, I navigate to the Task menu to run the List Report wizard.
A default SAS title and footnote is populated in each task as seen in the below window. You can enter your text or use the default text.

After going through the wizard the report is generated as seen below. In this example I ran the report for Honda cars only.

<table>
<thead>
<tr>
<th>Make</th>
<th>Model</th>
<th>Type</th>
<th>Origin</th>
<th>DriveTrain</th>
</tr>
</thead>
<tbody>
<tr>
<td>Honda</td>
<td>Accord EX 2dr</td>
<td>Sedan</td>
<td>Asia</td>
<td>Front</td>
</tr>
<tr>
<td>Honda</td>
<td>Accord EX V6 2dr</td>
<td>Sedan</td>
<td>Asia</td>
<td>Front</td>
</tr>
<tr>
<td>Honda</td>
<td>Accord LX 2dr</td>
<td>Sedan</td>
<td>Asia</td>
<td>Front</td>
</tr>
<tr>
<td>Honda</td>
<td>Accord LX V6 4dr</td>
<td>Sedan</td>
<td>Asia</td>
<td>Front</td>
</tr>
<tr>
<td>Honda</td>
<td>CR-V LX</td>
<td>SUV</td>
<td>Asia</td>
<td>All</td>
</tr>
<tr>
<td>Honda</td>
<td>Civic DX 2dr</td>
<td>Sedan</td>
<td>Asia</td>
<td>Front</td>
</tr>
<tr>
<td>Honda</td>
<td>Civic EX 4dr</td>
<td>Sedan</td>
<td>Asia</td>
<td>Front</td>
</tr>
<tr>
<td>Honda</td>
<td>Civic HX 2dr</td>
<td>Sedan</td>
<td>Asia</td>
<td>Front</td>
</tr>
<tr>
<td>Honda</td>
<td>Civic Hybrid 4dr manual (gas/electric)</td>
<td>Hybrid</td>
<td>Asia</td>
<td>Front</td>
</tr>
</tbody>
</table>
Task wizards can get reports very quickly without writing code. But you can add and change code if and when needed. After running a task wizard, the code that Enterprise Guide creates to generate the report is viewable and modifiable. I find this easy to copy this code into a new program and then make any necessary modifications. This allows you to leverage Enterprise Guide to write code and you continually learn SAS syntax. The window below shows the PROC REPORT code generated when running the Task List Report Wizard. The code is created and accessible to you from the Code tab in the Context Menu. This new feature of Enterprise Guide 4.2 allows users to modify and re-run tasks quickly and easily.

All available tasks are listed in the **Task** window. The screen shot below shows available tasks by name which is useful for seeing what code will be generated from running a particular task. The Description of the Task is in the first column and the corresponding SAS Procedure is in the second column. For instance, the Bar Chart Task uses PROC GCHART.
In some cases you want different types of results generated for different parts of a project. For instance, a bar chart outputted to a HTML file and a table to a RTF file. Under the Options tab from the Tools Menu, the Tools → Options → Results → Results General window shows the formats that can be generated by the SAS engine. The options are SAS Report, RTF, PDF, HTML, and text output. You can change this for all programs in the project or just for an individual program. To change this option for an individual program node you right click on the node itself and change the Results under the Properties tab.

BUILDING A REPORT FROM EXISTING SAS ITEMS AND TASKS

This section of the paper describes the SAS report building function with an example of how to build a report from SAS tasks and items. Most projects contain many output items (tables, graphs, charts, etc.) that all need to be assembled for a final report. Building a report with the use of the Report Layout function is a straightforward method for creating an end result of all your work. All tasks can be compiled into a single report and exported to a SAS Report, PDF, RTF, or HTML document.

To create a new report, you can use one of 3 methods,

1. Select File → New → Report
2. Right-click on the Process Flow area and select New → Report
3. Right-click on a SAS Report item and select Create Report

With any of the three methods above, a New Report window will pop open with the SAS items that you have created in your project (i.e., the bar charts and graphs, tables shown earlier in this paper). Please keep in mind the SAS item results will only appear if they were created in the SAS Report format (see earlier). That is, before running tasks, make sure that SAS Report box is checked from Tools → Options → Results → Results General window.

Continuing from the example above that uses the SASHELP.CARS data set; I create a report as a PDF file from tasks I previously ran (Donut chart, List Report). Once I create a report, the available SAS items are in the left pane of the window and can be dragged over to the Report Layout pane of the window to be organized (as seen in the window below). You can also add text and images to the report in this window.
Adding text and images are done using the buttons. They open windows that you can easily navigate. You can also add links to web sites or files. Edit text by double-clicking on the text in the report or by selecting the text and pressing the space bar.

Available images to add to your report include: BMP, JPG or GIF. Resizing images can be done by either dragging the handles (the small squares see below) or selecting the image and pressing ALT and the left, right, up, and down arrow keys. Additional features include exporting the report as a step in the project or directly. You can also email SAS Reports for others to view, change, or add.

You can preview any item in the Report Layout area with the Show Preview button. This is helpful because you don’t always remember the contents of all the SAS items (e.g., it’s difficult to remember the contents of the DonutChart in the example above). Previewing gives a quick way to see what items will be placed where. This does take some trial and error to get the items in the desired locations.

In my example I added text plus a header and footer to show where these additions will be placed. The final document is a PDF file complete with text, images, chart and header/footer. The first page looks like this.
THE DOCUMENT BUILDER

Another way to gather SAS tasks into one document is by using the Document Builder. This is for HTML results only. The window below shows a process flow where 2 Tasks create 2 separate HTML files that are then compiled into 1 HTML document using Document Builder. To create a HTML document, go to Tools → Create HTML Document. When the Document Builder opens you have the option to add a Task result (a HTML task created in your project), a document (this places a link to a HTML file outside of your project), notes (SAS notes created in your project), or a separator (line to separate HTML files). Other handy options include adding a table of contents and formatting your new HTML document with a SAS style.
Continuing with the example used in this paper, the resulting HTML document contains the donut chart and the list report in one HTML file with a table of contents located at the top of the file (location can be changed). It is hard to display the entire HTML in this paper, but the first section is shown below including the table of contents.

**AUTOMATING REPORTS WITH PROMPTS**

After creating and deciding on a final report for production, you can customize the report with prompts, or parameters as they are referred to in Enterprise Guide 4.1, for different requests or circumstances. For instance, you may get requests to run the same report for different clients, time periods, or some other subset of conditions. So the report would look the same but have different values. You can fulfill these requests by adding prompts that will prompt the user to enter parameters for the analysis/report. This feature is very useful for creating custom reports for multiple requests. Furthermore, this allows people less familiar to SAS to run your report with minimal effort. The user doesn’t need to know where and how to change code, just know that that the change was made.

**HOW TO CREATE PROMPTS**

Adding prompts is easily done by going to the **Prompt Manager** that is located in the Resources Pane (icon that looks like a globe) in the lower left corner of the Enterprise Guide interface. Or you can add a new prompt by selecting **View → Prompt Manager**.

Prompts are processed as macro variables. When Enterprise Guide prompts the user to enter values it then assigns these values to macro variables. Prompts can be included in a program, filter in a query or as variable name in a Task.

Prompts can include single or multiple values and users can enter values or select from a list of values (from a data set or user defined).

In my example, I create a prompt called “Origin” that will filter the Cars data set by the value the user enters. The first window that pops up is like the one below.
I add the prompt type and default values.

**ADDING A PROMPT TO A QUERY**

Once you add a prompt to the Prompt Manager, the prompt can be included in a program, filter condition in a query or as variable name in a Task. To add the prompt to a program, right-click on the program and select properties, then click Prompts and add the desired prompt to the program.

In this example I add the prompt to a filter condition in a query that will filter the Cars data set by the value the user enters for the Origin prompt. Subsequently this will change the process flow to create the report only for cars made in Asia.
Running the query with the addition of the prompt will pop up a window asking for the user to enter a value for Origin. Entering Asia in the prompt will result in a data set with observations where the origin variable = ‘Asia’.

The Process Flow shows the entire flow of this process. The cars data set is filtered with the use of a prompt that creates a data set from which a donut chart is created. This donut chart task is then part of a SAS report. Notice in the shot below that the Query Task icon includes a question mark which signals that this task has an associated prompt.
The result is a donut chart graphing the number of cars by type for cars of Asian origin.

### SAS® ENTERPRISE GUIDE® 4.3 AND 5.1

Newer versions of SAS Enterprise Guide have been released since I wrote this paper. I spent some time using this newest version and all the work described in this paper will work in EG 4.3. I do recommend updating to 4.3 as it has new features; the most noteworthy is a new program editor with autocomplete and integrated syntax help. These features complete and show syntax while you are coding (e.g., typing PROC and all available procedures pop up for you to choose from). Visit the [What's New in Enterprise Guide 4.3](http://www.sas.com/technologies/bi/query_reporting/guide/factsheet.pdf) website for details. Also, the paper [SAS® Programmer's Paradise: New Goodies in SAS® Enterprise Guide® 4.3](http://support.sas.com/documentation/onlinedoc/guide/tut42/en/menu.htm) by SAS Institute describes many of the new features of Enterprise Guide 4.3. For version 5.1, visit the [What's New in SAS Enterprise Guide 5.1](http://www2.sas.com/proceedings/forum2008/184-2008.pdf) for details.

### CONCLUSION

Enterprise Guide allows programmers to use both the heavy hand of SAS and the soft touch of EG to build and maintain repetitive reports. Adding a few lines of code or even using the many drop-down menus allow users to run programs efficiently and create great looking deliverables.

### REFERENCES

RECOMMENDED READING


CONTACT INFORMATION

Your comments and questions are valued and encouraged. Contact the author at:

Name: R. Scott Leslie
Enterprise: MedImpact Healthcare Systems, Inc.
Address: 10680 Treena Street
City, State ZIP: San Diego, CA 92131
Work Phone: 858-790-6685
E-mail: scott.leslie@medimpact.com or scottleslie@san.rr.com

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.